Ładowanie...
reverial.net
Kliknij, aby skopiować adres
Ładowanie...
discord.reverial.net
Kliknij, aby dołączyć
Avatar
Witaj na Reverial.net!
Aby dołączyć, zaloguj lub zarejestruj się.
Internet Explorer: Internet Explorer is not supported. Please upgrade to a more modern browser.
Brak wsparcia przestarzałych wersji
Temat zablokowany
DoreK Stwórca
826 postów
284 tematów
Lokalizacja: Warszawa
20 dni temu


Zmiana we wspieranych wersjach Minecrafta


Rozwój...
Minecraft cały czas się rozwija. Mamy już Snapshoty do wersji 1.20, a Reverial aktualnie tworzony jest na wersjach 1.17.1 oraz 1.19.2. Mimo to do tej pory (do momentu zawieszenia) obsługiwaliśmy wersje aż od 1.8. Wraz z reaktywacją zmienia się wiele - nowsze wersje, inna infrastruktura, inne oprogramowanie.

Nie możemy dłużej wspierać archaicznych wersji
Głównym powodem jest przejście na inne oprogramowanie (serwer proxy) służące do łączenia serwerów. Oczywiście domyślnie nic nie stoi na przeszkodzie by dalej wspierać 1.8-1.13, natomiast nowsza (i bezpieczniejsza z informatycznego punktu widzenia) metoda przekazywania informacji pomiędzy proxy a serwerami wymaga użycia wersji co najmniej 1.13. Bezpieczeństwo jest fundamentem sprawnego funkcjonowania serwera i uważam że jest to dobra decyzja. Mimo, że dotychczasowe zabezpieczenia całej infrastruktury były na wysokim poziomie (nikt do tej pory się nam nie włamał ;]), tak im lepiej tym... lepiej.

Starsze wersje przyciągają kłopoty
Wyobraźcie sobie gracza 1.8 który dołącza na serwer z 1.19.2. Myślę, że ponad 70% zawartości dla takiego gracza musi zostać wyświetlona w inny sposób, by zachować kompatybilność. Oznacza to że np. zamiast betonu będzie widział terakotę, a zamiast papug - nietoperza z nametagiem. To samo dotyczy każdej innej przestarzałej wersji.

Granie na tak starych wersjach nie jest niemożliwe, ale nie jest też komfortowe. Ponadto kolejnym problemem jest to, że na starszych wersjach łatwiej o różne cheaty i po prostu dziwniejsze community, które zatrzymało się w 2014 roku. Nie ma sensu dalej wspierać starych wersji Minecrafta - założenia Reverial są nieco inne.

Podsumowanie
Reaktywacja Reverial będzie działać od wersji 1.13 do najnowszej, z czego tryby będą bazowane na wersjach 1.17.1 oraz najnowszych. Możliwe, że ten stan się zmieni i wszystko będzie działać wyłącznie na najnowszej dostępnej wersji (poza np. lobby). Oznacza to, że nie będzie możliwości gry na wersjach od 1.8 do 1.12.2. Reverial.net dostępny będzie jedynie od wersji 1.13



🥒 OGÓREK 🥒